Thread: RS2Applet.class Error

Results 1 to 9 of 9
  1. #1 RS2Applet.class Error 
    Registered Member Cried Upon's Avatar
    Join Date
    May 2011
    Posts
    770
    Thanks given
    35
    Thanks received
    45
    Rep Power
    0
    I introduced my IRL bestfriend to runescape not to long ago and he bought a brand new Alienware m17x. He is running a Windows 7 64-bit operating system with 1TB of hard drive space and over 6 gigs of RAM. Whenever we use the downloadable client or either the website or swiftkit he keeps getting the error: RS2Applet.class Error Whenever he reloads the page it sais at the top left of the screen saying: "Error - Click here for details". Clicks on it and gives him the RS2Applet.class Error.

    What we've tried:

    1. Uninstalling all Java versions and deleting all of his Java directories...
    2. Installing the Java for the 32-bit Seach Engine.
    3. Installing the latest Version of java along with JRE and JDK.
    4. Using the downloadable client.
    5. Using an executable client such as the ones in the download section. Either way, neither of them work for it.

    Again what he's running:

    1. Windows 7 64-bit Professional Operating System.
    2. 1 TB (TeraBite) HDD (Hard Drive)
    3. 6 gigs or RAM over-clocked at 3.09GHz without boost.
    4. Intel I7 Duel Core Processor.

    Prize will be given to the first to successfully post a fix for this and it works. Thank you so much!!
     

  2. #2  
    MEIN FUHRER!

    Furor's Avatar
    Join Date
    Nov 2011
    Posts
    461
    Thanks given
    106
    Thanks received
    69
    Rep Power
    308
    Has he tried logging into the runescape homepage and then running the webclient?
    Has he tried google chrome and installed the java plugin?


     

  3. #3  
    Registered Member Cried Upon's Avatar
    Join Date
    May 2011
    Posts
    770
    Thanks given
    35
    Thanks received
    45
    Rep Power
    0
    Quote Originally Posted by Furor View Post
    Has he tried logging into the runescape homepage and then running the webclient?
    Has he tried google chrome and installed the java plugin?
    Yes as Google Chrome is his main web browser. Yes we did get the updated plugin which was the latest version of java and we installed it and still the same error. Yes, going to the website and using the webclient was the first thing we did.
     

  4. #4  
    MEIN FUHRER!

    Furor's Avatar
    Join Date
    Nov 2011
    Posts
    461
    Thanks given
    106
    Thanks received
    69
    Rep Power
    308
    Quote Originally Posted by Cried Upon View Post
    Yes as Google Chrome is his main web browser. Yes we did get the updated plugin which was the latest version of java and we installed it and still the same error. Yes, going to the website and using the webclient was the first thing we did.
    But did he log in first then open the webclient?
    The game wasn't running for me last week unless I logged into homepage first


     

  5. #5  
    Registered Member Cried Upon's Avatar
    Join Date
    May 2011
    Posts
    770
    Thanks given
    35
    Thanks received
    45
    Rep Power
    0
    Quote Originally Posted by Furor View Post
    But did he log in first then open the webclient?
    The game wasn't running for me last week unless I logged into homepage first
    The idiot fell asleep so gotta call his mom to wake him up. Then get on tv with him and do it through that and will tell you if it worked or not.
     

  6. #6  
    MEIN FUHRER!

    Furor's Avatar
    Join Date
    Nov 2011
    Posts
    461
    Thanks given
    106
    Thanks received
    69
    Rep Power
    308
    Quote Originally Posted by Cried Upon View Post
    The idiot fell asleep so gotta call his mom to wake him up. Then get on tv with him and do it through that and will tell you if it worked or not.
    Also try deleting the jagex cache if there is any @ C:


     

  7. #7  
    Registered Member Cried Upon's Avatar
    Join Date
    May 2011
    Posts
    770
    Thanks given
    35
    Thanks received
    45
    Rep Power
    0
    Quote Originally Posted by Furor View Post
    Also try deleting the jagex cache if there is any @ C:
    yes, did not work whatsoever :/
     

  8. #8 Re: RS2Applet.class Error (Question) 
    Registered Member johnk09's Avatar
    Join Date
    Nov 2011
    Posts
    1
    Thanks given
    0
    Thanks received
    0
    Rep Power
    0
    This seems to look very common in most cases, I've had that same problem before a few months ago and fixed up the solution to it.
    It maybe different depending how your system works, but did you uninstall everything related to Java (Including Oracle) from your computer and emptied out both the web cache and Jagex's cache?
    Last edited by johnk09; 03-18-2012 at 04:03 AM. Reason: General Reasons - Providing more feedback.
     

  9. #9  
    Maxing RS

    Snow Cat123's Avatar
    Join Date
    Nov 2008
    Age
    17
    Posts
    4,600
    Thanks given
    731
    Thanks received
    315
    Rep Power
    386
    install x86 hava and x64 then try through browser. If he wants to use the rsclient, I think there's only x86 and it gets installed to x64 path ? Try anything to switch between running the program in x64 or x86.
     


Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Class 8 error can anyone help?
    By youer3455 in forum Requests
    Replies: 1
    Last Post: 07-03-2010, 09:05 AM
  2. Replies: 21
    Last Post: 05-25-2010, 02:22 PM
  3. Class 9 error
    By GinGee in forum Help
    Replies: 0
    Last Post: 02-20-2009, 06:50 PM
  4. Class 9 error
    By GinGee in forum Help
    Replies: 2
    Last Post: 02-20-2009, 06:19 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •